Donald Johansson
2019-10-21T20:14:39Z
Hey, I just launched a new site with Hotcakes and saw that the page with the product details did not load as secure. I checked the code, and it appears the additional images loads with the http:// prefix instead of https.

Has anyone else noticed this? I checked out a few sites in the showcase and saw the same thing on those, so I don't think it's a problem with my customization.

This appears to affect any value that is populated using @altImg. Does anyone have any suggestion where to go to fix this?
Gilderroot
2019-10-22T03:51:29Z
Hi Donald,

I've come across a similar issue, I couldnt find a fix so I just wrote on the end of the image tag .Replace("http:", "https:")

<a href="@altImg.MediumlUrl.Replace("http:", "https:")">
<img src="@altImg.MediumlUrl.Replace("http:", "https:")" alt="@altImg.MediumlAltText" />
</a>

Seemed to have worked. Im sure there are better solutions.
Donald Johansson
2019-10-22T13:23:07Z
Thank you Gilderroot! That did the trick. All pages on my site are displaying as secure now.
Will Strohl
2019-10-22T18:17:23Z
In order to fully be SSL'd on your website, you'll need to "enforce" SSL in both DNN and Hotcakes Commerce.

https://hotcakescommerce...Settings-Store-Name-Logo 
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
Users browsing this topic
    Loading
    • Sign-up for the Hotcakes Community Newsletter: