mintblau media
2020-10-01T09:26:39Z
I have set up the category page and the product page with the product viewer module. In the store settings page configuration I have set it to the corresponding page. When I click on the product in category view the system tries to load the product page but then redirects back to the Home Page for logged out users. In Admin mode it goes to the product page but the product does not get loaded. The Viewer stays empty. When I select a product manually in the product viewer module settings it does show correctly. Guess it does not recognize the URL trail or something...

Any idea how to troubleshoot this? Using DNN 9.6.1 and latest Hotcakes. Thanks
Will Strohl
2020-10-01T22:16:08Z
Have you checked the permissions of the module and page where the Product Viewer is located? Does anything stand out to you there?

Does the product itself have any permissions specified?

Is there a specific view assigned to the Product View module? What about the product itself? If yes, is there any permission- or user-based logic in the custom view?

Is the Hotcakes Commerce URL provider still installed and enabled? Do you have advanced enabled for the DNN URL provider?
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
mintblau media
2020-10-07T14:57:04Z
Permissions of the module are set to page permissions. Page permissions are set to show to "All Users". Nothing stands out as far as I can tell.

Products have no special permissions attached. All are public.

Product view is set to standard index. Nothing changed yet in the view. It's a copy of the standard viewset.

Hotcakes URL Provider is active. All other URL Settings in screenshots:
https://d.pr/i/jBEGgY 
https://d.pr/i/YXvGAa 

Thank you 🙏
Will Strohl
2020-10-07T17:49:26Z
Your original post says that this is on DNN 9.6.1 but your screenshots look like an earlier version. Am I wrong?

Also, the other URL setting I was asking about is in the web.config.

<add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" />
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
mintblau media
2020-10-07T19:39:28Z
Yes, the web.config setting is exactly like this.

The first Screenshot was from a DNN which was set to English but has exactly the same settings. Here is the german one:
https://d.pr/i/n8xiBm 
Will Strohl
2020-10-07T21:39:11Z
Hmmm... This definitely sounds like either (1) permissions not properly assigned or (2) the page settings in Hotcakes Commerce are not properly wired up.

https://hotcakescommerce...tings-Page-Configuration 

The other thing that could impact this is if there are permissions assigned to the category or product in question.

https://hotcakescommerce...210315023-Category-Roles 
https://hotcakescommerce...210435723-Products-Roles 

Outside of that, are there any exceptions being logged to the Admin Log or the Log4Net log file when this happens?
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
mintblau media
2020-10-09T10:16:35Z
There are no roles set up for products or categories. And no error in the DNN Admin log for this. 😏
Will Strohl
2020-10-13T16:19:48Z
For anyone following this thread, we're working with Patrice via a support channel right now and will update this again once we know the cause and resolution.
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
Loading
  • Sign-up for the Hotcakes Community Newsletter: