Bryan
  •  Bryan
  • 82.5% (Honored)
  • Member Topic Starter
2019-07-09T04:39:32Z
Hi Al;l

I'm trying to set up FedEx shipping and hope someone can help here.

On the edit shipping mode page in the admin of Hotcakes I have entered all the keys etc and have then performed 'Test Rates' function and it will provide me with a shipping rate from FedEx but it does through the below error.

Starting Rate Test at 9/07/2019 4:27:17 PM
Rate Found: $170.61 | FedEx:International Economy (7, 43CF0D39-4E2D-4f9d-AF65-87EDF5FF84EA)

LOG:
FEDEX SHIPMENT | Negotiated rates were found and are currently being used.
Object reference not set to an instance of an object. | at Hotcakes.Shipping.FedEx.FedExProvider.RateShipment(IShipment shipment)
OPTIMIZED FEDEX RATE | Service Id: 43CF0D39-4E2D-4f9d-AF65-87EDF5FF84EA
Display Name: FedEx:International Economy
Service Codes:7
Estimated Cost:170.61
Finished Rate Test at 9/07/2019 4:27:19 PM


If I then attempt to calculate shipping in the checkout process using the exact same address then I get the shipping yet to be determined message and no shipping rate is calculated.

I have checked DNN admin logs and no further info is stored there.
note I am attempting to ship form NZ to Australia.

Will Strohl
2019-07-09T18:31:47Z
Hmmm... Do you have diagnostics turned on?

https://hotcakescommerce...13-Shipping-Method-FedEx 

When you test using checkout, are you using a shipping address that is supported by the configured shipping zone(s) and location(s)?

https://hotcakescommerce...-Shipping-Zones-Settings 

https://hotcakescommerce...65443-Settings-Countries 

Also, are the line items in the order marked and including details to support shipping?

Sometimes you need to play with the settings to get the result you expect.
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
Bryan
  •  Bryan
  • 82.5% (Honored)
  • Member Topic Starter
2019-07-18T00:15:29Z
Thanks Will,

yes I had diagnostics on but wasn't giving me the clues I needed. your instructions helped and once I fixed the configuration error I had made then everything seemed to start working.

Currently facing an issue where it's not pulling the expected rate but am yet to determine if that is an issue at our end or with FedEx themselves.
Loading
  • Sign-up for the Hotcakes Community Newsletter: