VineelG
  •  VineelG
  • 51.75% (Neutral)
  • Newbie Topic Starter
2018-04-03T10:14:20Z
Our production and staging instances are in same server and have similar domain name ( like dev.domain.com and www.domain.com ). Everything is working fine, but when we try to configure custom order workflow in staging, Extensibility and Views manager is pointing to production folder. Unable to find where this can be modified, please assist with this issue and provide information in configuring Hotcakes in another instance with similar domain name.

Thanks
Will Strohl
2018-04-08T18:57:44Z
Since the issue is occurring in your custom order workflow, the problem is likely related to your custom code. The path in question is likely hard-coded in your workflow. You may need to debug your code to determine your custom code to determine where this is occurring to resolve it. Sometimes, a simple search may work as well.

A longer-term resolution for this would be to try and match your development/staging environment paths to production or have the path be a configuration setting somewhere. This will prevent this issue from occurring again in the future.

If you'd like more formal assistance with this, you should consider hiring us to resolve the issue for you, or we can also give you a higher level of support via Developer Support Services. Links to both are below.

https://upendoventures.com/What/Hotcakes-Commerce 

https://upendoventures.c...mmerce-Developer-Support 
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
VineelG
  •  VineelG
  • 51.75% (Neutral)
  • Newbie Topic Starter
2018-04-09T14:47:23Z
Thank you Will. The problem is with the folder path, our staging server is pointing to, even before integrating our customized code. In order to map our customized View set, we need to be able to select them in Extensibility, but the ViewSets populated in the list are from production website folder, not from staging website folder.

I don't think there any path in the customized code that is effecting, as same code and configuration is working in our Dev server and QA server. And this is happening after removing entire customized code dlls from the website(even though they weren't configured to use). Is this because of the conflict with similar Domain names ( dev.Domainname.com vs www.Domainname.com )? Is there any setting that I can change to resolve this?

Thank you for your valuable time.
Will Strohl
2018-05-15T16:21:45Z
There isn't anything in Hotcakes that would instinctively point to a specific folder when moved from environment to environment. You'll want to review your configuration options you've set in both DNN and Hotcakes, and also in the customizations made in the extension points. This is a very vague and high-level issue. I'm afraid that I can't help much more through the forums. 😞
Will Strohl, Upendo Ventures
Hotcakes Cloud  | Get Support  | Code Support 
Official Cloud & Support provider for Hotcakes
Loading
  • Sign-up for the Hotcakes Community Newsletter: