PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 6/23/2019 12:47 AM by  MooreCreative
Razor errors after Installing HotCakes 3.0.1 Module version into upgraded DNN 8.0.4
 9 Replies
 0 Subscribed to this topic
 1 Subscribed to this forum
You are not authorized to post a reply.
Page 2 of 2 << < 12
Author Messages

New Member

1/31/2018 10:11 AM
I've got the exact same error. Any luck yet with solving the problem?

New Member

1/31/2018 10:45 AM
No. i couldn't figure out what the issue is or how it can be fixed. Hopefully @Moorecreative should be able to help

Basic Member

7/5/2018 2:07 PM
I had emailed/messaged back a bit with Idas and Prathyusha, hoping that I could reproduce the same problem on one of our servers but in the end wasn't able to create a setup where that extra MVC Dependency DIDN'T solve the problem for us... as in, any time I put that extra dependency into the web.config, it solved the problem instantly.

This week I did an upgrade from a 3.0.1 Hotcakes instance to a 3.2.0 instance... after the module installed and updated the site's HotCakes version, I noticed that the same store, category and product page issues occurred again... the upgrade of the module undid the dependency in the site's web.config(?). All I did was add back in the dependency record and the HotCakes modules all loaded correctly again.

Basic Member

6/22/2019 10:12 PM
This week I'm doing another Hotcakes DNN upgrade from 1.10 up to 3x as well as moving DNN from 7x up to 9.

Already, in the first step of just moving the Hoctakes instance from 1.10.3 to 1.10.4 I received a similar error message after the module install/upgrade.

In this situation, the XML in the web.config had a blank value for xmlns like this:

removing the xmlns="" allowed me to move forward another step in install/fix

Additionally, in another upgrade step, I noticed that some error messages after update were regarding the older dlls which Hotcakes put in place vs the DNN 8x dlls that had been there earlier.

I would recommend checking on the version of these dlls and manually updating them in the /bin/ folder and in the webconfig


** Note that the System.Web.MVC is most likely version I had set at one point and that had issues, checking to the DLL, it was 5.1.20129.0, so is the proper number for the dependentAssembly reference

Basic Member

6/23/2019 12:47 AM
and then one more related when getting to HotCakes 2 x versions (when having already allowed for the MVC 5x in the web.config) is that every HC 2x upgrade step kept setting this value

and that needs to be

to match the MVC 5x state.
You are not authorized to post a reply.
Page 2 of 2 << < 12

  • Sign-up for the Hotcakes Community Newsletter: